A memory corruption vulnerability exists in Exim versions 4.69 and older (CVE-2010-4344). Exim is the mail transfer agent used by cPanel & WHM.
This update has been rated as Important by the cPanel Security team.
A memory corruption vulnerability has been discovered in Exim. This vulnerability may lead to arbitrary code execution with the privileges of the user executing the Exim daemon. cPanel previously released RPMs that mitigated the severity of the vulnerability on December 9, 2010 (CVE-2010-4345). This notification is for the release of new RPMs which remove the remote memory corruption vulnerability in its entirety. The vulnerability relies upon "rejected_header" being enabled (default setting) in the log_selector configuration.
To resolve and work around the issue on Linux systems, cPanel has issued new Exim RPMs. Server Owners are strongly urged to upgrade to the following Exim RPM versions:
Systems configured to use Maildir: Exim 4.69-26
Systems configured to use mbox (deprecated): Exim 4.63-5
Exim RPMs will be distributed through cPanel’s package management system. All cPanel & WHM servers receiving updates automatically will receive the updated Exim RPM during normal update and maintenance operations (upcp). To begin an Exim update on cPanel systems immediately, run the following command as root:
FreeBSD systems should be running Exim 4.72 by default, which is not affected by this issue.
This notification covers CVE-2010-4344.
The notification release earlier on December 10, 2010 with the summary "A privilege escalation vulnerability exists in Exim, the mail transfer agent used by cPanel & WHM." covers CVE-2010-4345. At the time of the earlier announcement, the CVE had not been assigned.